Why did I receive a "version incompatible" message when launching Astropad?

This occurs when your iPad app has been updated and your Mac app hasn't, or vice versa. 

To resolve this issue:

  1. From your Astropad Mac app, navigate to Astropad > Check For Updates.
  2. From your iPad, open the App Store and touch the Update tab on the bottom, then touch the update button next to the Astropad app if it is present.

If the problem still persists:

  1. Delete the existing Astropad app from your iPad and re-download it from the App Store
  2. Delete the existing Astropad app from your Mac and re-download the latest version from our website here: https://www.astropad.com/downloads

Still need help? Contact Us Contact Us